Windows Security Center reports Antivirus and/or Firewall are turned off

Most of the times, when Security Center reports Bitdefender Antivirus and/or Firewall are turned off, it is just a display issue. In other words, while Bitdefender is working properly protecting your PC the status displayed in Action Center is showing otherwise not being able to check the real status.

There are three main steps you should follow to resolve this:

• Try to turn them ON from Action Center

• Make sure Bitdefender Antivirus and Bitdefender Firewall are working properly

NOTE: skip this step if you have Bitdefender Antivirus Plus or if Action Center is not reporting that Firewall is disabled

• Refresh Windows Security Center checking list

 

1. Try to turn them ON from Action Center

• If there is only one option you can click on Turn on now > then “Yes, I trust this publisher and I want to run this program”.

• If there are multiple choices please click on View antivirus programs/View antispyware programs/View firewall options and choose to turn on the Bitdefender feature(s).

• If the issue persists go to the next step.

 

2. Make sure the Bitdefender Antivirus and the Bitdefender Firewall are working properly

• Bring up the main Bitdefender interface and go to the PROTECTION window;

• Click on the Settings button in the lower-right corner of the ANTIVIRUS module;

• Make sure the switch next to Bitdefender Shield is set to ON;

• Go back to the Protection modules.

• Make sure the switch in the FIREWALL module is set to ON;

• If the features are OFF try turning them ON and then check if the issue persists;

 

3. Furthermore, follow the steps below to refresh Windows Security Center checking list

a) Open an elevated command prompt as follows

Click the Windows Start menu from the bottom left corner and type in cmd.exe

Right click on on the Command Prompt search result, and then choose Run as administrator

b) In the command prompt window type the command below and press Enter

winmgmt /verifyrepository

c) You will get either one of these results:

WMI repository is consistent – no problems detected >> go to step f)

WMI repository is inconsistent – problems detected >> go to step d)

d) To rebuild the repository type the command below and hit Enter

winmgmt /salvagerepository

e) You will receive one of the results below

WMI repository is consistent – no problems detected >> go to step f)

WMIrepository salvage failed – failed to rebuild WMI repository. Try repeating step d) again.

WMIrepository has been salvaged – WMI repository has been successfully rebuilt. >> go to step g)

f) Reset the repository to its initial state using the command below and hit Enter

winmgmt /resetrepository

g) Now reboot the PC and check if the issue reoccurs

Related Articles

Was this article helpful?
Rating: 1.0. From 24 votes.
Please wait...

Sorry about that

How can we improve it?

For any issues with Bitdefender you can always contact us using this form

Popular How-To Videos